XSplit Broadcaster Software Manual

Sources

Sources are the building blocks of scenes. Mixing various sources is the cornerstone of being creative in XSplit Broadcaster. This section describes the various sources available in XSplit Broadcaster.


Screen Capture

Screen capture can be used to capture a desktop or a window. When you choose screen capture from the source list, a targeting reticle [ ] will appear on your screen. This allows you to highlight either a desktop or a window to capture. Once you have decided on what you wish to capture, you can hold down the left mouse button to select a specific region of the desktop or window capture:

Once you have selected your window or desktop, you can right click on it in the source list for further adjustment:

Desktop Capture (Screen Tab)

Desktop capture allows you to adjust the region of the capture via the sliders at the top.

Window Capture (Screen Tab)

Window capture give you a few more options. The first is Exclusive Window Capture, which allows you to place other windows on top of the captured window. Second, it also allows you to specify if you just want to capture the Client Area or inner window or the entire window. Finally, you can set it to Stick to Title, where it will only capture a window if it has the same name as the initial window capture (this is useful if you accidentally close a window).

Both desktop and window capture allow you to choose if you want to capture layered windows and if you want to show the mouse and mouse clicks.

Current Limitations with Screen Capture

Any Hardware that uses Windows 7 with Aero theme:

Desktop / Desktop Region / Non-Optimized Window Capture / Non-Optimized Window Region capture is rendered at a maximum of 15 FPS. If you want to capture high motion content, you need to use optimized window capture.

Laptops with Switchable Graphics (Nvidia) and Windows 7 / Windows 8+:

If you are running XSplit Broadcaster on the dedicated GPU, we do not recommend capturing Desktop / Desktop Region / Non-Optimized Window Capture / Non-Optimized Window Region. We only recommend capturing Window or Window Region with the optimized option enabled.

Game Capture

Game Capture uses the game source feature to capture your PC Games and add them as a source in XSplit Broadcaster. Game source works with DirectX 9, 10, 11, and OpenGL games.

To add a compatible game, go to Add Source > Game Capture. If there is a game running, you will see it listed in the game capture menu. You can either add a game manually or you can use the Auto Detect feature. The Auto Detect feature will switch between whatever game windows are active:

To configure a game source, right click on it in the source list and click on the Game Tab:

Here, you have the option to show your mouse in the game capture and enable special optimization. Special optimization uses a different way of capturing frames in your game, which may enhance your performance. Unless you are using an NVIDIA SLI or AMD Crossfire setup, we recommend you enable special optimization. Finally, you can select an image to be shown (via Offline Image) when there is no game detected.

Media Files

Media files are video files, audio files, or image files that are added to XSplit. Unlike many other sources, you can add a media file as a source by simply dragging and dropping it onto XSplit Broadcaster's stage.

To configure a media file, right click on it in the source list and then click on its First Tab:

Note: The first tab of the an image source has fewer options than a video or audio source.

  1. Playback: This section controls how a file will play back on a scene.

    The top section gives media player controls such as the Timeline, Pause / Play / Stop / Rewind / Fast Forward controls, and Volume controls:



    The audio output section allows you to choose whether the media file's audio outputs to system sound or only to the stream/local recording:



    In the next section (Start at), you can set where your video starts and ends. You can also choose what action the file will take when it is finished playing. The options for When Finished are Nothing (no special action will be taken once the video is finished playing), Rewind, Loop, Hide (this will uncheck the media file as a source), and Transparent (this will cause the file to become transparent as a source):



    Below When Finished, you can choose if you want the media file to start when the scene loads. Next, if you check the box of Remember Playback Position, the media file will start from the point the video was at when you last switched scenes. Third, checking the box of Force deinterlace will cause the video to be deinterlaced (when you deinterlace, you convert the material that contains alternating half-pictures to one that displays a full picture at a time). Last, checking the box of Show playback position will cause XSplit to add a playback counter at the bottom right of the video:



  2. Media Source: This section allows you to change the media source via a file browser.

  3. Cue Points: You can add cue points for various actions to the media file. The available actions are Resume, Pause, and Cut (which will reset the media file back to the starting point). You can remove cue points by click the "x" symbol in the Saved cue points list.

Webcam, Capture Card, and Video Devices

XSplit Broadcaster can accept a wide variety of video inputs. In this source menu, you will find any supported and properly connected web cam, capture card, or firewire video device.

To add a video device, click on Sources, point to Webcam, capture card, video devices and click on the device you want to add:

To configure a video device, right click on it in the source list then click on the Cam Tab:


  1. Playback: Here, you can pause the video capture, add a delay, and you can also adjust the audio of the video device if an Audio Input is selected. Please note that this volume setting is not global so you will have to adjust it for every scene you add the video device to.

    Since some video devices build the captured audio in a separate graph, you can use the Audio Input option to combine these inputs into a single source. You can also choose any device that is connected as a recording device in windows.

    The Audio Output can be set to system sound or stream only/local recording. If you have a capture device added to a scene that has a delay, like USB 2.0 capture cards, you can use stream only.

    Finally, you can enter an Offset (a delay in milliseconds) to better synchronize the audio input and video input.

  2. Camera Source: Here, you can swap between different camera sources that are connected to your PC.
  3. Device Configuration: This is where you can configure various aspects of your video device.
    1. Video Output: Here, you can set the output of the video sent from the capture card to the XSplit stage. Common settings include the Frame Rate of the video capture, Color Space Compression used, and output resolution (Output Size) of the video capture.

    2. Audio Input: If you have set an audio input device, you can make adjustments in the audio input menu. Generally, the only option available is to be able to adjust the volume of the audio input.

    3. Video Input: In this window, you can adjust the video input of the capture device. This menu can look different between devices, but generally the options are to adjust Brightness, Contrast, Hue, Saturation, and the type of source being captured (HDMI, Component, Composite, DVI, etc.).

    4. Crossbar: The crossbar is similar to Video Input in the way that it lets you adjust the source the capture card will receive for both audio and video. Using the crossbar you can switch between digital sources (HDMI, DVI) and analog sources (Component, VGA).

    5. Force Deinterlace: This option will de-interlace the video feed you receive from the video device (when you deinterlace, you convert the material that contains alternating half-pictures to one that displays a full picture at a time).

IP Camera

You can add an IP camera to XSplit Broadcaster as a video source if you have its RTSP URL (you can find this URL in your IP camera’s manual or bundled software). Simply click on Sources point to Webcam, capture card, and video devices and select RTSP IP Camera:

This will prompt you to enter its RTSP URL. If you are not sure what it is, you can look for it in your IP camera’s manual or bundled software:

Once you add the IP camera to the scene, you can right click on it in the source menu for further configuration:

 

  1. Playback: Lets you adjust the volume of the IP camera.
  2. Stream Source: Here, you can change the RTSP URL for the IP camera source.

Audio Devices

Any device that is recognized as a “recording device” (inside Control Panel > Sound > Recording) by Windows can be added as an audio device in XSplit Broadcaster.

To add an audio device, click on Sources, point to Audio devices and click on the device you want to add:

Once you have added an audio device, right click on it in the source menu to configure it:

  1. Playback: Here, you can set the volume of the audio device. Please note that this is not a global setting and will need to be set for each scene the audio device is added as a source.

    By default, the Audio Output is set to stream only, as setting to system sound will create a feedback loop. You can also set an Offset to sync the audio device with video devices on the scene. Finally, you can enable Silence Detection to mute or unmute the audio device if it does not pass a certain threshold. You can read more about Silence Detection in the Audio Section.

  2. Audio Source: This drop down menu allows you to switch audio devices.
  3. Device Configuration: This lets you access the Audio Input section, which allows you to tweak some properties like the input volume of the audio device:

Text

To add text sources, click on Sources and click Text:

Once you add a text source, a source properties window will immediately appear:

Content

Here, you can enter the text you want to display. You can use HTML commands such as <br> in this field to modify the text. You can also activate and open the custom scripts editor by checking Use Custom Script and clicking on Edit Script:



Which will allow you to select a template:

Blank Template: Use this template to create your own custom script using Javascript. Click on the Script Tab to enter your Javascript and then click on the Settings Tab to adjust whatever parameters your Javascript provides.

General Purpose Clock: The general purpose clock template offers a variety of time-based functions as a Text source:

Basic Settings

  1. Mode: This changes the function of the general purpose clock.

    1. Clock - turns the general purpose clock into a 12 hour clock.

    2. Clock24 - turns the general purpose clock into a 24 hour clock.

    3. Count - turns the general purpose clock into a counter. The counter can either count towards or away from a set date and time.

    4. Date - makes the general purpose clock display the date of the system clock.

    5. Duration - makes the general purpose clock count up from when the script is activated.

    6. Timer - makes the general purpose clock count down from a designated interval.

  2. Text Before: Enter the text you wish to appear before the general purpose clock.

  3. Text After: Enter the text you wish to appear after the general purpose clock.

Count Mode Settings

  1. Date: Enter the date you wish the general purpose clock to count away or towards.

  2. Time: Enter the time you wish the general purpose clock to count away or towards.

  3. Starting Format: The starting display format. This can be either MM:SS or SS. Once the time unit reaches its maximum value, the next time unit will be added to the display, regardless of the selected starting format.

Date Mode Settings

  1. Date Format: This setting switches the date format between short and long. Short displays the abbreviated day of the week, day, month, and year (for example, “Thu 01/01/15”). Long displays the full day of the week, day, month and year (for example, “Thursday, January 1, 2015”).

Timer Mode Settings

  1. Minutes: Lets you set the minute value to count down from.

  2. Seconds: Lets you set the second value to count down from.

  3. Starting Format: The starting display format. This can be either MM:SS or SS. Once the time unit reaches its maximum value, the next time unit will be added to the display, regardless of the selected starting format.

  4. Hide Extra Zero: If you don't want any leading zeroes to be added to your time unit (for example, you don't want to display the first zero in "01:00” and you want to see "1:00" instead), check this box. This only affects single digits (for example, "01" to "09").

Load Text from Local File: This template allows you to load text from a text file saved on your PC:

  1. File Path: Click on the three dots to open a file browser and select the text file you wish to pull data from.

  2. Delimiter 1: Delimiters are used to specify the section in the local text file where data will be pulled from. A delimiter in the <***> format tells the script where to begin pulling text from the local file. Once you have set a delimiter here, you will also need to add it to your local text file.

  3. Delimiter 2: Delimiters are used to specify the section in the local text file where data will be pulled from. A delimiter in the </***> format tells the script where stop pulling text from the local file. Once you have set a delimiter here, you will also need to add it to your local text file.

  4. Update Interval: This is the interval (in seconds) when the  script will check your text file for updates or changes.

  5. Behavior on Line Breaks: This setting determines how the script handles line breaks (paragraphs) in your text document.

    1. Preserve Line Breaks - maintain the format of your line breaks of all text pulled from the file.

    2. Ignore Line Breaks - ignores all line breaks and text characters will be continuous when there is a line break.

    3. Replace - replaces all line breaks with whatever is entered in the “Replace Line Break With” section.

  6. Replace Line Break With: Enter the characters that you wish to replace line breaks with.

Load Text from Remote URL: This template allows you to load text from a URL:



  1. Url to Load: Type in the link to the URL you wish to pull data from.

  2. Delimiter 1: Delimiters can be used to specify sections in the local text file to pull data from. A delimiter in the < *** > format shows the script where to begin pulling text from the remote url. Once you have set a delimiter, you also need to add it to your remote text file.

  3. Delimiter 2: Delimiters can be used to specify section in the local text file to pull data from. A delimited in the </***> format shows the script where stop pulling text from the local file. Once you have set a delimiter, you also need to add it to your remote text file.

  4. Update Interval: This is the interval in seconds that the  script will check your text file for updates or changes.

  5. Behavior on Line Breaks: This setting will determine how the script handles line breaks (paragraphs) in your text document.

    1. Preserve Line Breaks: This will maintain the format of your line breaks of all text pulled from the file.

    2. Ignore Line Breaks: This will ignore all line breaks and text characters will be continuous when there is a line break.

    3. Replace: This will replace all line breaks with whatever is entered in the “Replace Line Break With” section.

  6. Replace Line Break With: Lets you enter whatever characters you wish to replace line breaks with.

RSS Feed Reader: This template will pull text from an RSS feed of your choice:


  1. RSS Feed URL: Here, you can enter the URL of the RSS feed you wish to pull text from.

  2. Number of Entries: Lets you specify the number of most recent entries you wish to display. The limit is 100.

  3. Separate Entries With: Allows you to enter the characters that you want to use to separate your RSS feed entries. You can also use HTML code in this section like <br> to have line breaks between RSS entries.

Video List: The video list script allows the titles of video files to be displayed in a video playlist:

  1. Mode: Lets you choose to have the video title Always Show or to disappear after a Timed interval.

  2. Disappear: Allows you to set the time in seconds for the video title to show.

Format

In this area, you can style the text you entered in the Content Area (see the previous section called Content for more information):

Font: Lets you choose the color and the type of font you wish to use.

Outline: Here, you can select the color and thickness of an outline for your font.

Opacity: This slider can be used to set the opacity of the text. You can manually enter a value in the box to the right or use the up and down arrows to adjust.

Style: Allows you to style the look and alignment of your font. You can set bold, italics, or underline. And you can also align the font to left, center, right, top, middle, or bottom.

Shadow: Allows you to apply a “shadow effect,” to your text. You can tweak its distance, angle, blurring, and opacity.

Animation

This is where you can apply animation effects to your text.

  1. None: No animation.

  2. Scroll: Here, you can set your text to scroll in a variety of directions and speeds:

       

    1. Direction: The four directions you can set your font to scroll to:

      1. Left to right

      2. Right to left

      3. Top to bottom

      4. Bottom to top

    2. Speed: Set the pixels your text scrolls per second. You can manually enter the value in the value in the box on the right or use the the up and down arrows to adjust the value.

    3. Line Limit: When there are line breaks (<br>) in your text and you have vertical scrolling enabled (top to bottom or bottom to top) this setting will adjust the amount of lines displayed during the scrolling.

  3. Fade: This allows you to create a fade effect for your text:

    1. Delimeter: The delimeter can be one character (e.g. "|") or more (e.g. "||") that will be used to separate the text into segments for each fade effect.

    2. Interval: This is the time the text will be displayed before another fade effect is applied.

    3. Fade speed: This controls the speed of the fade animation.

Other Sources

There are a variety of other sources you can add to your presentation, such as: hitbox Chat Viewer, Image Slideshow, Input Visualizer, Newtek NDI Stream, RTMP Stream, Skype Video, Starboard, TrackTL, Twitch IRC Chat Viewer, Twitch Chat Viewer via HTML5 Chat Viewer, Video Playlist, Webpage URL, Whiteboard, Youtube Chat Viewer, and Youtube Chat Viewer via HTML5:


Hitbox Chat Viewer

The hitbox Chat Viewer allows you to display hitbox’s chat in your broadcast.

To add it to your scene, click on Add > Other > hitbox Chat Viewer, then right click on it to show its source menu:


  1. Source: Type the name of your hitbox channel and click Connect. If you are able to connect successfully, the contents of your channel will be shown in the stage.
  2. Display: This area allows you to customize the look of your hitbox chat.
    1. Chat Box: Controls the background color of the chat
    2. Opacity: Slide to the left to increase transparency and to the right to decrease it.
    3. Viewers: Lets you choose a color and font for you and your viewers names.
    4. Message: Allows you to select the color and font for all the messages.
    5. Text Size: Adjusts the text size to what you type in.

Image Slideshow

Image Slideshow allows you to create a slideshow from a variety of image sources (.JPG, .GIF, .BMP, , .PNG, .JPEG, .TIF, .TIFF and .TGA).

To add it to your scene, click on Add > Other > Image Slideshow. Once its added, you will immediately be taken to its source menu:


  1. Images: Here, you can add images via the file browser (multiple images can be added at once). And you can remove images and preview the images you’ve added. Images can also be sorted using the arrows on the right or via drag and drop.
  2. Effects: This area allows you to customize the look of your slideshow.
    1. Transition: In this area, you can select different transition effects for your slideshow. You can see how the transition effect looks in the preview box to the right.
    2. Loop: Allows you to set loop actions for the image slideshow.
      1. Once then hide: Loops the slideshow once, then hides (uncheck) the image slideshow in the source list.
      2. Once: Loops the slideshow once, with the last image added being still.
      3. Forever: Loops the slideshow endlessly.
    3. Interval: Lets you set the time between images in seconds. You can also allow the images to be shuffled and for the image slideshow to remember the last active image when switching scenes.

Input Visualizer

The Input Visualizer displays your key presses and button clicks on screen.

To add it to your scene, click on Add > Other > Input Visualizer. For the Input Visualizer to work, it needs to have permission to execute scripts. To give it permissions, click on Edit access now:

Then check its box under “Allow access on checked” and click OK:

Once it has permission, it will show you which keyboard and mouse buttons you pressed by lighting them up on the screen:

Note: If you don’t see Input Visualizer in the list of plugins, click on Sources > Get more sources… then type Input Visualizer in the search box then click on it once to go to its page then click Install.

Newtek NDI Stream

NDI is NewTek's new protocol that can allow software and hardware to interact with each other via a LAN network.

One of the most common feature requests we’ve received is for an easy way to allow players to display multiplayer gaming sessions with their friends. Now, as long as you have a router with open ethernet ports, you can achieve this with NewTek NDI.

Creating Multiplayer Gameplay Content

Let’s say you have a friend over to play Overwatch with, and you want to share both your screens on your stream. If you are connected to the same LAN network, have your friend open up XSplit Gamecaster and go to the Settings Tab. Inside the settings tab, check the “Enable NewTek NDI Output” box:

https://lh3.googleusercontent.com/6r05N_muIBg1NXngaZ-PRngQ5-u6t-3K3U2HO595AF8Ckde7-n3G9NKn1FYAn1OyNtzx4FwJDzQ8JSeAtCuN8lD3o4lhZcaveRW99t9BmYyepgqOFx36DmapZ1Yy1fD71FOWVv71

On your PC, launch XSplit Broadcaster and go to Sources > Other > NewTek NDI Stream and select the broadcast from your friend’s PC:

Now you can arrange your scene as you like and create multiplayer content with your friends!

Connecting XSplit Broadcaster with NewBlueFX Titler Live Broadcast

One of the biggest benefits to NewTek NDI is that it allows XSplit Broadcaster users to gain access to a wide array of high end production software. One of these is NewBlueFX’s Titler Live Broadcast. Titler Live Broadcast allows you to easily create dynamic 3D graphics similar to what you see during sports broadcasts with scoreboards and lower thirds. Using NewTek NDI, you can easy bring your Titler Live Broadcast graphics and animations in your XSplit Broadcaster scene.

To use XSplit Broadcaster with Titler Live Broadcast, open it then go to Settings > Device and select the NDI option:

Then add the NDI output from Titler Live Broadcast to XSplit Broadcaster by going to Sources > Other > NewTek NDI stream and selecting the machine that is running Titler Live Broadcast:

Once you have positioned Titler Live Broadcast’s NDI output on your scene, anything you display in Titler Live Broadcast will also appear in XSplit Broadcaster:

And that shows just how easy it is to use different applications with XSplit Broadcaster via NDI. There are also countless other ways you can use NewTek NDI with XSplit Broadcaster, so please make sure to follow XSplit on social media for more NewTek NDI guides. To learn more about NewTek’s NDI Technology, click here.

RTMP Stream

If you have an RTMP URL along with its stream name, you can add an RTMP Stream as a source in XSplit Broadcaster.

To add it to your scene, click on Add > Other > RTMP Stream. Once it has been added,, a source window will open:

  1. URL: In the first box, you can select from a variety of RTMP formats (rtmp, rtmps, rtmpt, and rtmpe). In the next one, you can enter the actual RTMP URL.
  2. Stream Name: This is where you enter the stream name also known as the stream key.
  3. Buffer: In this area, you can set the buffer (delay) for the stream.

Once you have added the RTMP source, right click on the source menu for additional options:


  1. Playback: In this section, you can adjust the volume of the RTMP stream. Please note this is not a global setting so you will need to set it for each scene you add the RTMP stream as a source.
  2. Stream Source: This lets you can change the RTMP information you entered when the source was first added.

Skype Video

Skype video allows you to add you Skype video calls as a source. Once Skype video is added as a source, simply begin a video call in Skype and it will appear in XSplit Broadcaster. Please note that Skype video does not support group video calls.

To add it to your scene, click on Add > Other > Skype Video. After adding it to your scene, right click on it in the source list for further customization:

Offline Image: Here, you can select the image that is displayed when a Skype video call is not active. If no image is added, then the source will become transparent when not in a call.

Starboard

The starboard is a scorekeeping source that is designed to work with Starcraft 2.

To add it to your scene, click on Add > Other > Starboard. Once you add the Starboard as a source, right click on it in the source list and then click on the configure button:


Which will open this window:


Player Area: Here, you can configure the information for the left and right player, such as Starcraft 2 race, score, color, and score reset.

Sub Bar Text: Lets you enter text that will appear below the starboard.

Announcement Text: Allows you to enter text that will appear above the starboard.

Tracktl

This plugin works with Tracktl to display a music playlist that is curated by your stream viewers.

To add it to your scene, click on Add > Other > Tracktl. Once it’s added, right click on it to login to your Tracktl account:

If you’ve logged in successfully, you should see something similar to this:

In the Source area, you can select a Trackparty and you'll be given its URL. You can also choose whether to allow your users to add copyrighted content to the tracks (Note that copyrighted tracks may not be allowed for streaming in some services such as Twitch):

Under Display, you can choose a theme and set its Opacity:

To give you a preview of what it looks like, here it is with the “Light” Theme:

Note: If you don’t see Tracktl in the list of plugins, click on Sources > Get more sources… then type Tracktl in the search box then click on it once to go to its page then click Install.

Twitch IRC Chat Viewer

The Twitch IRC Chat Viewer allows you to display Twitch’s chat in your broadcast.

To add it to your scene, click on Add > Other > Twitch IRC Chat Viewer. After its been added, right click on it to show its source menu:



  1. Source: Type the name of your Twitch channel and click Authorize.  After authorizing, click Connect. Once you are able to connect successfully, the contents of your chat will be shown in the stage.

  2. Display: This area allows you to customize the look of your hitbox chat.

    1. Chat Box: Controls the background color of the chat

    2. Opacity: Slide to the left to increase transparency and to the right to decrease it.

    3. Viewers: Lets you choose a color and font for you and your viewers names.

    4. Message: Allows you to select the color and font for all the messages.

    5. Text Size: Adjusts the text size to what you type in

  3. Animation: This lets you choose an animation.

    1. Scroll: Lets you dynamically scroll user chat messages across the screen using your specified direction and duration. It also lets you manipulate text size, text color, and hide usernames:

Twitch Chat Viewer via HTML5

The Twitch Chat Viewer via HTML5 allows you to display Twitch’s chat in your broadcast using HTML5. This version of the Twitch Chat viewer aims to have a faster loading time and use fewer CPU resources over the conventional Twitch IRC Chat plugin.

To add it to your scene, click on Add > Other > Twitch Chat Viewer via HTML5. Once it has been added, right click on it to show its source menu:

  1. Source: Type the name of your Twitch channel and click Connect. Once you are able to connect successfully, the contents of your chat will be shown in the stage.

  2. Display: This area allows you to customize the look of your hitbox chat.

    1. Chat Box: Controls the background color of the chat

    2. Opacity: Slide to the left to increase transparency and to the right to decrease it.

    3. Viewers: Lets you choose a color and font for you and your viewers names.

    4. Message: Allows you to select the color and font for all the messages.

    5. Text Size: Adjusts the text size to what you type in.

Note: If you don’t see Twitch Chat Viewer via HTML5 in the list of plugins, click on Sources > Get more sources… then type Twitch Chat Viewer via HTML5 in the search box then click on it once to go to its page then click Install.

Video Playlist

The Video Playlist source allow you to assemble multiple videos to play back at once. When you add the video playlist source, a source menu will immediately appear:

  1. Playback: In this section, you can control the playback of the video files. You can adjust the volume and use the playback controls to play, pause, stop and skip between video files. You can set the Audio Output of to media files to play back through system sound or to stream only (only will appear on broadcasts). In the next section, you can setup the behavior of the playlist when you switch to it in a scene. Once the playlist is over, you can set it to do nothing, rewind to the first video, loop, hide from the source list, or become transparent. You can also set the playlist to start when the scene loads, to remember the playback position of the playlist when leaving the scene, and to show the counter of the playback position in the bottom left corner of the video playlist source.
  2. Videos: Here, you can add, remove and order videos. Videos can also be unchecked if you’d like to temporarily remove them from the playlist.

Webpage URL

The Webpage URL allows you to add a webpage as a source to XSplit Broadcaster. It’s basically an internet browser built into XSplit Broadcaster. After you select Add > Other > Webpage URL..., a window will appear asking you for the URL:

Once you have added the Webpage source, right click on it in the source list and click on the HTML Tab:

  1. Playback: This area lets you control the volume of the web source along with your chosen Audio Output. You can output audio to the default playback device (default speakers) or to stream only (audio will only appear in broadcasts).
  2. HTML Source: Here, you can change the URL you wish to add as a source.
  3. Display: In this section, you can alter how the web page is displayed in the stage. Resolution allows you to set a custom resolution to resize your webpage to. You can disable transparency on a web page added as a source. And you can also disable scrollbars for web pages that are larger than the resolution of the stage.
  4. Custom Code: In this section you can enable the use of Custom CSS and Custom JS (JavaScript) for your webpage source. If you check the box of either custom option, click on the corresponding edit button to enter your CSS or Javascript:

Whiteboard

The whiteboard source allows you to draw on the XSplit stage using a mouse. When you add the whiteboard source to a scene, right click on it in the source list and click on the Whiteboard Tab in the source menu:

  1. Drawing: This area is where you can customize your whiteboard drawing.
    1. Tool: Currently, the only tool is freehand drawing (However, more tools will be added in the future). If you hold down the shift key, shape detection gets activated. So, if you try to draw a shape like a circle while holding down shift, then the drawing will be modified to a circle based on detection.
    2. Size: This setting is the size of the line of your drawing. You can quickly adjust this size by using "S."
    3. Color: Here, you can choose the color of your drawing.
  2. Hotkeys: There are a variety of hotkeys that can be used with the Whiteboard source. [S] will toggle the size of the drawing lines. [Shift] will activate the alternate function of a tool. [D] will save the current drawing. [Esc] will clear the whiteboard.

General Source Menu Options

When you enter the source menu, generally speaking, there are usually three tabs available for customizing the source: Color, Layout, and Effects.

Color Tab

The color tab allows you to adjust a variety of image effects along with applying effects like chroma key:

  1. Picture: Here, you will find a variety of image effects to apply. Values can be entered manually, via slider, or using the up/down arrows on the keyboard:
    1. Brightness: Lightens or darkens the image.
    2. Contrast: Increases or decreases the separation between the darkest and brightest areas of the image.
    3. Alpha: Increases or decreases the opacity of the image.
    4. Hue: Adjusts any color in the source between a red, green, and blue scale.
    5. Saturation: Increases or decreases the separation between colors in a source.
    6. Background Color: Allows you to add a background color to sources that don’t have a background like the Text Source.
    7. Full dynamic range: Checking this box converts the color range of a source from 16-235 to 0-255.
  2. Keying: Keying is the combining of visual elements from separate sourcings into one. XSplit Broadcaster allows for keying to be done through the removal of colored backdrops with Chroma Key and Color Key.
    1. Chroma Key: Chroma Key is a type of keying that uses standard colors like green, blue, and red for background removal. Chroma key has two modes, standard and legacy mode:
      1. Standard Chroma Key

        1. Key Color: Sets the color for background removal. Available options are Green, Red, and Blue.
        2. Anti-aliasing: Smooths the edges around the background removal. Higher settings will require more CPU usage.
        3. Threshold: Increases or decreases the amount of the key color to remove.
        4. Exposure: Adjusts the brightness of the source to help give a better chroma key effect.
      2. Legacy Chroma Key

        1. Eyedrop Tool: Clicking on this tool, then onto a color in the source that you want to remove will help to quickly set the key color.
        2. Anti-aliasing: Smooths the edges around the background removal. Higher settings will require more CPU usage.
        3. Manual Key Color Settings: The first two sliders are used to select the key color to be removed.
        4. Alpha Smoothing: Adjusts the edges around sections that have the key color removed.
        5. Saturation: Increases or decreases the amount of the selected key color to remove.
        6. Brightness: Lightens or darkens the source to help with color key removal.
    2. Color Key: Color Key is a type of keying allows the user to remove a specific color.

      1. Eyedrop Tool: Clicking on this tool, then onto a color in the source that you want to remove will help to quickly set the key color.
      2. Anti-aliasing: Smooths the edges around the background removal. Higher settings will require more CPU usage.
      3. Threshold: Increases or decreases the amount of the key color to remove.
      4. Exposure: Adjusts the brightness of the source to help give a better color key effect.
      5. Manual Key Color Settings: Use the red, green, and blue sliders to manually set the color to remove.

Layout Tab

The layout tab is used to configure the size and positioning of your source in a scene:

  1. Position: This section allows you set the size and position of your source.
    1. X/Y: Sets the position of your source along the X/Y axis. You can enter values by manual input, by using the slider, or by using the up/down arrows on the keyboard.
    2. Width/Height: Sets the width and height of your source. You can enter values by manual input, by using the slider, or by using the up/down arrows on the keyboard.
    3. Keep Aspect Ratio: Uncheck this option to be able to set the width and/or height outside of the original aspect ratio of the source.
    4. Lock Position: Activate this to disable the ability to adjust the position of the source on the mixer. The X/Y and width/height sliders can still be used.
    5. Enhance Resize: Activate this to enhance the image quality of a source that has been resized.
  2. 2D/3D Transform: This section allows you to adjust your source on a 3D axis:
    1. X: Adjust your source along the X axis. You can enter values by manual input, by using the slider, or by using the up/down arrows on the keyboard.
    2. Y: Adjust your source along the Y axis. You can enter values by manual input, by using the slider, or by using the up/down arrows on the keyboard.
    3. Z: Adjust your source along the Z axis. You can enter values by manual input, by using the slider, or by using the up/down arrows on the keyboard.
    4. Flip: These buttons can be used to quickly flip your source along the X or Y axis.
    5. Rotate: These buttons quickly rotate the the source in 90 degree increments along the Z axis.
  3. Cropping: Cropping allows the removal of sections of a source from the left, right, top, and bottom edges.
  4. Top and Bottom: Remove sections of the top and/or bottom edge of the source. You can enter values by manual input, by using the slider, or by using the up/down arrows on the keyboard.
  5. Left and Right: Remove sections of the left and/or right edge of the source. You can enter values by manual input, by using the slider, or by using the up/down arrows on the keyboard.
  6. Auto Crop: Clicking on Auto Crop will leaves the task of determining which the sections of the source to crop to XSplit Broadcaster.

Effects Tab

The Effects Tab allows effects to be added when a source is enabled or disabled in the source list:


Masking
 
Masking lets you clip the source to the shape of the mask.
 
Shape lets you select a pre-defined shape as your mask:
 

File allows you to select a file as your mask:
 

Here’s what a source looks like before applying a mask:
 

And here’s what it looks like after (a rounded mask was used to achieve this effect):


 
Transition
 
The transition works when you show or hide a source in the scene.  
 
Transition lets you choose between 12 transition effects (Clock, Collapse, Fade, Fan, Hole, Move Left, Move Right, Move Left-Right, Move Top, Move Bottom, Move Top-Bottom, and Wave). The preview box on the right will show what the transition effect looks like:
 

Speed allows you to set the duration of the transition effect in milliseconds:


 
Please note that you can show or hide a source by checking or unchecking its box in the source list:

Miscellaneous Source Menu Items

  1. Sticky: Activating sticky will save the settings for a global source such as a Webcam whenever it is added to another scene. It will also prevent the source menu from disappearing when the mouse is not hovering over the source menu.
  2. Keep source in memory: Activating keep source in memory will load the source into the PC’s RAM, which helps speed up the loading of a source when a scene switches. Some sources like webcams require this to be active.
  3. Reset: The reset button resets the values of the section where it is present.
  4. Refresh: This will reset a source within XSplit Broadcaster. For some sources like a webcam, the source’s graph will be completely rebuilt.

Forgot your password?

Did you forget your password? No worries! Enter your email address below we'll help you gain your access back.